Rails 4.0 will drop support for Ruby 1.8.7

Posted by: Peter Jones on

Back in 2010 when Ruby on Rails 3.0 was released the core team dropped support for Ruby 1.8.x except for version 1.8.7. With 4.0 scheduled for a release sometime in the Summer of 2012 all versions of Ruby 1.8 will officially be dropped:

There’s not a lot of details about what we’re going to include in Rails 4.0 yet as the primary purpose for bumping the major version number is to drop Ruby 1.8.7 support.

This coincides with the Ruby core team dropping support for 1.8 this Summer as well.